Хорошие книги по Excel и VBA

Несколько книг по Excel и программированию на VBA, которые я рекомендую своим ученикам и использую сам.

Excel 2013
Книга главного гуру Excel Джона Уокенбаха. Увесистый талмуд, который нет смысла читать от корки до корки – обращайтесь к нему как к справочнику по любым вопросам. Именно что по любым (ну, почти) – очень широкое покрытие тем. Есть даже раздел по основам макросов, позволяющий получить базовое представление о них. Формулы и графики рассматриваются подробно.
Надо заметить, что такие книги Уокенбах делает по каждой версии. 2007, 2010 и 2013 отличаются не так сильно между собой, и я до сих пор обхожусь книгой по 2010 версии.
В российском издании версия по 2010 версии сделана на чуть более плохой бумаге, но с более качественными скриншотами.
Хочу отметить большую работу российских издателей книг Уокенбаха – они локализовали все примеры и файлы.
Formulas 2013
Эта книга лучше по исполнению, чем “Библия пользователя”. Хорошая бумага и иллюстрации.
Подойдет, если вы уже знаете азы и хотите углубиться в сводные таблицы, формулы, анализ данных. В книге есть примеры и детальное описание базовых функций Excel, формул массива, сложных и малоизвестных формул (например, РАЗНДАТ, которой нет в мастере функций и в списке автозавершения – ее можно ввести только вручную, если о ней знать) и – что, пожалуй, самое ценное – продвинутых формул, созданных из нескольких функций (как, например, формула, позволяющая найти вхождение какого-то текста в ячейку – я писал про нее ранее)
Хотя короткие основы Excel даются и здесь – так что если вы не совсем новичок, от первой книги можно отказаться в пользу этой.
Несколько примеров полезных формул из книги:
Формула, позволяющая вычислить номер квартала по дате:
=ОКРУГЛВВЕРХ (МЕСЯЦ(A1)/3;0)
Подсчет количества уникальных значений в интервал (формула массива):
{=СУММ(1/СЧЁТЕСЛИ(Интервал;Интервал))}
Поиск ближайшего значения в диапазоне (ищем ближайшее к “Цель” число из массива “Данные”)
{=ИНДЕКС(Данные;ПОИСКПОЗ(НАИМЕНЬШИЙ(ABS(Цель-Данные);1);ABS(Цель-Данные);0))}
Эффект чередующихся строк в условном форматировании:
Создаете условие на формулу:
=ОСТАТ(СТРОКА();2)=0
и красите ячейки нужным цветом.
Cond format
Таких вот примеров в книге сотни. Мой экземпляр весь в стикерах – отмечал любопытные и полезные идеи.
Лучшая книга по Excel для тех, кто занимается анализом, статистикой, отчетностью, работает с большими массивами.
Excel 2013 VBA
Самое полное и качественное руководство по созданию макросов в Excel. Выручала во многих ситуациях, очень помогала создавать сложные проекты на VBA (а-ля автоматическое создание аналитических отчетов в Word на основе управленческой отчетности в Excel).
В комплекте с книгой автор предлагает файлы со всеми примерами, рассмотренными в ней. Их очень много. Это бесценный материал, который позволяет на практике очень быстро учиться писать макросы, сочетая “метод тыка” с информацией из книги.
Кстати, такие же файлы-примеры есть и по первым двум книгам в этом обзоре.
В 95% случаев ответ на вопрос по Excel мне удается найти в одной из этих трех книг Уокенбаха. Его книги объемнее и дороже бесчисленных “самоучителей”, представленных на рынке. Но лучше один раз вложиться в них и иметь качественную информацию под рукой, чем вестись на кажущуюся простоту самоучителя, обещающего быстрое и фундаментальное освоение материала 🙂
Tips and Tricks
Эта книга для тех, кто любит формат “лайфхаков”, готовых решений.
Для фундаментального освоения Excel, в отличие от первой книги из списка, не подойдет, но зато с высокой вероятностью поможет быстро решить текущую рабочую задачу. В книге 100 советов в духе “Как сделать две диаграммы одинакового размера”, “Обнаружение лишних пробелов” и Удаление знаков “минус” из отрицательных чисел”.
Sleptsova
Очень хорошая книга российского автора. Ее большое преимущество в том, что в ней рассматривается создание макросов во всех приложениях Office, а не только в Excel. Интереснее всего, конечно, Word.
Отмечу, что язык VBA мало меняется и не зависит от версий. Долгое время я пользовался книгой “Excel 2003. Профессиональное программирование на VBA” и только к выходу 2013 версии обзавелся новым изданием. Так что и в случае с этой книгой пусть вас не смущает 2010 год в названии.

MrExcel XL: The 40 Greatest Excel Tips of All Time

MrExcel
Автор проекта http://www.mrexcel.com/ собрал 40 любимых трюков, добавил 40 лучших клавиатурных сочетаний и собрал 30 лучших идей от профессионального сообщества – в честь 30-летия Excel.
Все это подробно проиллюстрировано скриншотами и – иногда – прикольными карикатурами.
Книга для тех, кто действительно угорает по Excel – в ней есть, помимо перечисленного, “периодическая система горячих клавиш” – очень полезная штука; шуточки про Excel (Where do spreadsheets go to drown their errors? The formula bar) и даже коктейли Excel – это вообще неожиданно 🙂 Power Pivotini, Ctrl+B и Stacked Column Shot – есть из чего выбрать (все с подробными рецептами и фото).
Если без шуток, книга очень мощная. Мой экземпляр весь в стикерах и пометках: есть и простые, но неизвестные лайфхаки, есть и сложные приемы, и все с отличными примерами.
И, конечно, рекомендую лучший (на мой взгляд) русскоязычный сайт про Excel – Планета Excel.
Там тьма полезных статей и видеоуроков. Кстати, у автора этого сайта есть своя книга с готовыми приемами и решениями. И она предлагается с файлами-примерами. Рекомендую.

Оставьте комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

CAPTCHA image
*